Download Bolt 2.1

    09 Mars 2015  

      Bolt 2.1

 Information

Changements notables:

Ajouté: Autoriser le protocole https: // dans un paramètre canonique dans config.yml. (Voir le numéro 3044)
Ajouté: localisation taïwanaise (zh_TW). (# 3022, merci @ Leon0824)
Correction: Mettez à jour les objets de champ CKEditor s'ils existent dans les sauvegardes de contenu AJAX. (Voir n ° 2998)
Ajouté: un enregistrement de journalisation pour la mise à jour et la désinstallation d'une extension (voir # 2993)
Ajouté: validation côté client (d'abord pour les flottants). (Voir n ° 2997)
Changement: le champ float n'est plus le champ numérique html5, et les deux, et. sont autorisés comme séparateur décimal.
Modification: la distribution inclut désormais les fichiers composer.json.dist et composer.lock.dist, si vous en avez besoin.

Ajouté: Autoriser les extensions à être utilisées comme contrôleurs (non statiques) (Voir # 2971)
Correction: les noms de types de conttent longs sont maintenant tronqués correctement dans la barre latérale. (Voir le numéro 2513)
Correction: Ne perdez pas les informations d'identification de la base de données en cas d'erreur de connexion lors de la configuration. (Voir n ° 2538)
Modification: Supprimez jquery-catchpaste inutilisé.
Changement: Nombreux changements (pour le mieux) dans la journalisation: Monolog, interface utilisateur améliorée, séparation des problèmes.
Refactor: Nombreuses modifications et améliorations apportées à l'objet Config.
Refactor: Nettoyage majeur dans Bolt \ Storage, Bolt \ Events \ StorageEvents et Bolt \ Content (# 2664)
Mise à jour: PHPUnit couvre maintenant la base de code complète (# 2542, merci @rossriley)
Mise à jour: l'interface des extensions a subi une refonte majeure et utilise désormais plus largement l'API Composer. Elle offre une meilleure gestion des erreurs pour les appels AJAX sur la page Étendre (# 2543 grâce à @GawainLynch).
Mise à jour: le fournisseur de journalisation personnalisé de Bolt a été remplacé par Monolog (# 2546, merci @GawainLynch)
Ajouté: Extension repo as service: extrait les requêtes du référentiel Extensions vers un fournisseur de services distinct. (# 2550 merci @rossriley)
Ajouté: Achèvement de la commande BASH / ZSH pour Nut (voir # 2657)
Mise à jour: Magnific popup est maintenant à 1.0.0. (# 2560, merci @cdowdy)
Mis à jour: FlySystem de la version 0.5 à 1.1, avec le correctif php5.3. (# 2587)
Correction: tableaux dans le type: sélectionner des champs. (# 2609)
Ajouté: Autoriser les clés: slug dans le type: sélectionner des champs, pour personnaliser le champ utilisé réellement stocké dans la base de données. (# 2597)
Correction: Petit correctif logique pour 'groupingSort'. (Voir le numéro 2520)
Corrigé: Est-ce que Cache :: clearCache () utilise $ app ['ressources'] -> getPath ('racine') pour le répertoire 'thumbs' (Voir # 2512)
Corrigé: Bug de la casse dans la réinitialisation du mot de passe (voir # 2616)
Ajouté: La modification du contenu affiche désormais les modifications récentes consignées (si activées) avec un lien vers la comparaison des modifications (Voir # 2620)
Corrigé: Correction du HTML mineur et lien cassé dans le thème base-2015 (# 2650, merci @apatkinson)
Correction: imbriquer les dossiers dans le cache 2 profond. (Voir le numéro 2644)
Correction: bug corrigé dans "Sélectionner dans tous les éléments" de la vue d'ensemble. (Voir n ° 2669)
Corrigé: Correction du nom de la liaison de la route des navigateurs de fichiers sur 'archiveur de fichiers' (voir # 2680)
Corrigé: Autorise le paramétrage du motif regex, le remplacement et la casse des noms de fichiers téléchargés (Voir # 2691)
Correction: Une régression qui empêcherait de définir des variables Twig globales dans une extension (voir # 2717)
Modifié: appliquer le changement de configuration SSL. Maintenant, nous utilisons uniquement enforce_ssl, cookies_https_only est obsolète. (Voir # 2726, merci @ dwolf555)
Correction: le tableau retourné remplace les arguments dans parseFieldsAndGroups (). (Voir n ° 2738)
Corrigé: plus de & nbsp; indésirables dans CKeditor. Corrections # 2660
Correction: l'utilisateur connecté ne peut plus se désactiver
Correction: Désactiver un utilisateur connecté avec forcer une déconnexion
Correction: Correction d'un bug avec certains caractères utf8 devenant des points d'interrogation après l'enregistrement dans la base de données. (Merci @dwr, voir # 2804)
Correction: Correction # 2424 et autres améliorations du groupe d'onglets # 2801 (TODO: Spécifiez!)
Ajouté: Les extensions installées utilisent désormais par défaut l'ajout de contraintes de version pour permettre une mise à jour plus facile
Changement: l'en-tête X-Frame-Options est maintenant envoyé uniquement pour les pages principales et peut être désactivé dans config.yml (voir # 2825).
Changement: Bolt fait maintenant la distinction entre les «informations régulières» et les «alertes» sur l'écran du tableau de bord. De cette façon, nous pouvons mieux informer les personnes en cas de problème de sécurité urgent. (Voir n ° 2830)
Correction: Le jeton anti-CSRF intégré a été renommé en bolt_csrf_token pour éviter les conflits lorsqu'un utilisateur possède un champ appelé jeton. (Voir n ° 2831)
Modification: vous pouvez maintenant utiliser {id} dans les itinéraires pour les enregistrements au lieu de {slug}, si vous souhaitez avoir des liens vers des enregistrements utilisant l'identifiant. (Voir le numéro 2832)

posté par un
administrateur le 09 Mars 2015
Taille du script
Version
CAT  Catégorie
Fichiers
Site
Action
6 Mo - 6496 Ko
2.1
 version  CMS
18
1 762
SCRIPT
  • Downloader  Bolt 2.1


  • L'ajout de commentaire est libre et ne demande pas d'inscription,
  •   invité

nous vous encourageons à contribuer à l'utilisation de PHP en ajoutant vos sources.

  Moteurs - Plateformes - SQL

  Scripts PHP/MySQL